N26 Open Banking - Degraded performance affecting Payment Initiation

Incident Report for Tink providers France

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Feb 18, 2025 - 08:54 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Feb 11, 2025 - 09:59 UTC
This incident affected: N26.