Crédit Mutuel - Degraded Performance

Incident Report for Tink providers France

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Apr 03, 2025 - 01:23 UTC

Investigating

We are currently investigating an issue with Crédit Mutuel.
Posted Apr 02, 2025 - 21:35 UTC
This incident affected: Crédit Mutuel.