BRED Banque Populaire - Major outage affecting Account Information and Payment Initiation

Incident Report for Tink providers France

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Mar 25, 2025 - 09:04 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Mar 09, 2025 - 20:02 UTC
This incident affected: BRED Banque Populaire.