Crédit Mutuel de Bretagne Transactions - Partial outage
Incident Report for Tink providers France
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Mar 07, 2024 - 07:04 UTC
Investigating
We are currently investigating an issue with Crédit Mutuel de Bretagne.
Posted Mar 06, 2024 - 10:06 UTC
This incident affected: Crédit Mutuel de Bretagne.